Mobiscroll Cli - unable to bundle the angular package


I have downloaded angular package from download builder and trying to integrate with my application, by copying the lib folder in src folder of my application.

Whenever i try to run the command mobiscroll config angular --no-npm I run into below error :

mobiscroll config angular --no-npm
Mobiscroll configuration started.
Could not write to file C:\*******\my-app\package.json. 
Error: EISDIR: illegal operation on a directory, read
If the problem persists get in touch at

I have made sure my directory is not read-only, but its not helping either. Everytime i run the command, its sets the folder to read only mode.

I recently updated my mobiscroll cli version to 1.3.0 after which i’m facing this issue.

Can you please help me to resolve this issue?

mobiscroll - cli - 1.3.0
Npm - 6.11.2
node - 12.13.1


Hi Anu,

Thanks for reaching out!

So far we didn’t meet with this error. I’ve tested with the same node/npm versions which you are on, but unfortunately I wasn’t able to reproduce the error. For me the no-npm config is working without any problems.

Did you changed your npm configs recently? This error might be related to your local configs.

Is this the full error log which you are getting? If there are more logs, can you please share the whole error log, maybe that can offer some additional information!