Hierarchy Listview issue on iOS, using version 4.1.1


#1

You guys broke the Hierarchy ListView on iOS.

Clicking a 1st level hierarchy item will automatically click through to the next level hierarchy item on the iphone (if there is a next level clickable item in the same place on the next screen). This also affects the back button.

I spent quite some time trying to debug this finding that it wasn’t anything I had to done to cause this. The only other thing I had changed was moving from 4.3.2 to 4.4.1. After going back to 4.3.2 everything went back to normal.

This only is seen on iPhone. My android builds were not affected.

I would like to see a fix for this so I can take advantage of the other bugfixes and changes.

Thank you
Michael DeMutis


New release: Mobiscroll 4.4.1
#2

Hi Michael,
I could not reproduce the issue so far.
Could you specify the iOS version where the issue occurs?

Thanks,
Isti


#3

Latest version, iOS 12.

I’ve attached a video. The first part is just showing you that I have 2 listViews. The swipe action listView and the hierarchy listView.

https://drive.google.com/open?id=1BBt4wq9qCVCgeaq2fAVpq1pAXTWha1V4


#4

Hello isti -

I took your code and put it into my app and compiled it.

Result was the same. The listview clicks fire twice as does the back button. I have attached another video.

This is happening when compiled into an iOS app using Phonegap Build / Apache Cordova.

To note, I am only using the same jquery.js that you used in the demo, your css files and the mobiscroll 4.4.1 version included in your zip file. This doesn’t happen on 4.3.2.

The also doesn’t happen when run from a web browser, it only occurs when its compiled down to an iOS app.

I’m wondering if you have a non-minified version of mobiscroll that I could use for testing where I could revert each of your changes one by one until I find the issue?


#5

Thanks for the details. Indeed, I only tried on iOS Safari, and not inside a Cordova app.
I’ll try with Cordova as well.
Meanwhile could you try adding the following css and see if that solves it:

.mbsc-lv-cont {
    touch-action: manipulation;
}

Let me know the results.


#6

That didn’t fix it. Same thing happening.


#7

Ok, I managed to reproduce this with a Cordova app. It’s only happening if UIWebView is used, which is the default with Cordova, this should not be an issue if using WkWebView.
The issue is present starting from 4.4.1, where we did some changes for form elements inside listview to work properly. While we come up with a proper fix for this, passing the tap: true setting to the listview should solve this.
Let me know if this helps!


#8

Do you mean like this?

I added that and it’s still not working. I think I will just use 4.4.0 and wait for the next version before upgrading.


#9

Hi MIchael,

This is now fixed in v4.4.2

Let me know if it works for you as well.