Cant type in popup on iOS


#1

This issue just appeared the other day as the app had been working correctly for a few months. The user cannot type in a text/textarea field in a popup on ios (12.2) in a cordova app. The keyboard pops up and the cursor is blinking inside the input.

Not exactly sure of the version of Mobiscroll (where can I find that?) but it was downloaded Jan 10, 2019. Inputs outside the popups are working correctly and all browsers are working fine as well.

Here is how the popup is being initiated:

positionSelect = mobiscroll.popup('#positionSelect', {
	theme: 'ios',
        display: 'bubble',
        anchor: navPath + '.choosePositions',
        scrollLock: false,
        cssClass: 'mbsc-no-padding md-content-scroll',
        closeOnOverlayTap : false,
        buttons: [{
            text: 'OK',
            handler: 'set'
        }],
        onSet: function (event, inst) {
	       logic ...
	    }
    })

I have also tried adding ‘-webkit-user-select: text’ to the input as well, but that did not help.

Thank you for your help!


#2

Welp, I just updated it to version 4.7.3 and that fixed it. Weird that it was working fine for a while then broke. Was there an update in the past few versions that addressed that?


#3

Hi @JeremyD :wave:

Happy to see you figured it out!
Here you can find the our Release history: https://mobiscroll.com/releases :wink: